Perform concatenate operation at list sublevel

Hi, I would like to create a list constaining [x1,x2,x3,x4…] by concatenating a string “x” to a sequence. The string. concat is not performing properly

How can I tell Dynamo to concatenate at sublist level?. According to the popup help, it should be working.

Please note that I am using Dynamo 2.0: is not available

Like so:

Fine, thanks.

can you explain me why my code was not working?

The String.Concat “Concatenates multiple strings into a single string” as described in the Node (place your mouse over the Node).
That’s why you get 2 indexes. One with the “x” and another with the strings all together.

OK, I had already realised about that,but I was confused about the fact that the vectorial product indicated an output list pattern that adjusted to my requirements, but it seems to be a general help. not valid for this specific node.

that’s correct.
If the second post/reply solved your question please mark it as “solved”.


Well, the other answer is the solution to the problem, while your answer is the explanation of what was going wrong. Unfortunately, I cannot mark both of them.

Thanks for the help!!

Generally this can be useful for understanding the core nodes:
There are even examples showing how they work :slight_smile:

I know @JFK already gave a explanation just wanted to throw in the Dynamo Dictionary as it is quite useful (Along with the Dynamo Primer)

Thanks a lot. I had been looking for the scripting language reference without luck. I will probably end using python o c# for programming part of the scripts, the visual programming graphs seem to be difficult to maintain in large dynamo projects.

I thought that too, but it’s in there. It’s called Map from the search.

Not liking the new Library search or Right Click behavior, 1.3 seemed to accept all my typos and mind read what I wanted.

Thanks for the info. According to the documentation, is to be replaced in most of its functions by the use of Levels, so it may be worth to consider it as a obsolescent feature.

I fully agree with you: I am following a Dynamo 1.3 course and the search works much better in the previous version. The queries do not allways work, you are nor redirected to the node tree when you query by right clicking… Node drag and drop is missing… Also, the small codes which indicated the type of node (creation, query, etc) have now been replaced by a dynamo logo, useless. Can we go back to the old interface, please? This seems to be a step back.