Making sense of script error

I still have my Dynamo training wheels on and still am enjoying the creative side of this, but I have what again might be best described as rookie problem…

Currently I am hoping to stumble across a tool that works for dimensioning walls with openings (windows, doors, etc.). I haven’t figured it out yet, but have been reading/trying alot of what the community has posted. This is both interesting (to see all the approaches) and very frustrating (because it seems to work for others but not for me). So, I opted to start with what seemed like the easiest beginner version to try and troubleshoot and hoping to work myself towards the most comprehensive version I have seen here.

All while I cannot get this specific script to return any dimensions (that’s another question I guess), what I find the most vexing is the returned error messages. I’ve googled them and seem to have a slight grasp as to what they are referencing but I am still very confused. I’m nearly positive when i followed the fantastic DynaMaps walk through on YouTube a very similar situation existed with a

Code Block > Curve.NormalAtParameter

I have attempted to blindly walk through this issue but to no resolve.


I have tried to troubleshoot this without harassing the masses and realize I’m not giving the correct input because it is expecting something different. That is exactly where my knowledge runs out.

I appreciate any assistance you all have!

Don’t worry about the wheels we all ahve them in some form or another :slight_smile:
In your case the error i’m guessing is that the outout of the Element.ElementCurveReferences might not be a curve.
Can you show us the what’s coming out of it please.

And don’ stop asking questions… ever :slight_smile:


@Daniel_Hurtubise I like exploring just a tad bit more than asking questions… sounds like I might be good fit!

In the above, nothing is coming out. That is to say, I’m not seeing anything on Revit when I hit Run. Maybe everything works fine and I stumbled across this unknown gem of a command:


@Daniel_Hurtubise here is a grab from the sample file (and .dyn file) I’ve been working off of.

wall dimension_simplified v2.dyn (27.2 KB)

This is what i’m referring to when i ask what’s coming out of the node

Thanks @Daniel_Hurtubise for the clarification, I’m learning new things all the time.

Here’s the node (look at me using correct terms now :grinning:) results:

Curve.NormalAtParameter input for parameter is 3…
A parameter is a way to define the location along the curve starting at 0 and ending at 1.
3 meaning you are … wayyyy past the end of that curve :slight_smile:
Try values between 0 and 1

Thanks @Daniel_Hurtubise, that makes perfect sense about the parameter value being between 0 and 1.

However, changing it still generates the same error.

Here’s the whole thing:

You’re feeding in curve references and not curves.

good catch @viktor_kuzev. Still learning my way around, which curve node should I use instead?

There is a node called Edge.CurveGeometry, which turns edges to curves.
I’m not familiar with the node you’re usingto get the wall edges, but some of its outputs might already be curves, check for that.

Interesting, I’ve made the change but still resulting in errors. Not sure how else to troubleshoot but I’ll keep plugging away at it.