Making PDF with multiple views


As you can see this prints only one page on the PDF, I want to print multiple pages with on each page a view I set in Dynamo anyone got any idea how I do that?

1 Like

Set print range on Current might do the trick(?).

NB
These forums really need some overhaul or so.
Seen this question multiple times now without a (real) solution… :roll_eyes:

1 Like

Yeah I know searched a lot but never found a good solution sadly setting it to current isn’t it either :frowning_face:

Have you tried this? image

2 Likes

@JacobSmall

I have read multiple topic about this (print to PDF and print and combine PDF with different sizes)
and also tested different things myself. I never got it to work either…


Print.dyn (46.6 KB)

I also looked at / read through these topics, but none provided a solution
for batch printing (different sized) Sheets… At least not that i am aware of.

https://forum.dynamobim.com/search?q=batch%20print%20different%20sizes

I also tried most of the solutions in those topics (i.e. replacing the Phyton code).

Without a solution in any of those topics or said it can’t be done topics like these
will keep comming back.

1 Like

Yeah I did, for as far as I could see its only able to combine 2 PDF files afterwards not multiple views

Hmm, yeah I’m afraid it is going to be an endless search I’ll try to get it working for some more weeks and then maybe come with a conclusion. Thank you for your response.

The solution lies probably somewhere in ALL these topics (combined).
It seems that for batch plotting the best solution is to look for a (payed for) add-in
(i.e. DiRoots or PF Printer?) instead of Dynamo.

I really don’t get it why there is no OOTB solution for this. Maybe @JacobSmall can tell us why.

Yeah it doesn’t even seem that hard of a problem because what this node does is always print it on page 1. Shouldn’t be to hard to make it print on page 2 or further but no node exist for it it seems.

As far as i know (read; guess) is that every Node creates single pdf’s first and afterwards
tries to combine those pdf’s. In the combining lies the issue.

From Batch plot to pdf

But MergePFDs is not working

After some more looking into stuff i came accross this

Didnt try this myself yet

1 Like

Ah thanks a lot I’ll give that a try

Hi Dylan and @bvs1982,

Fortunately, this problem has already been resolved :grinning:

Here is an example :


Batch Print PDF Merge.dyn (29.5 KB)

I could have made the “Combine multiple sheet into a single file” option work in the Print PDF node.


But Revit can’t combine sheets of different formats. This would work only for sheets of the same size.

And for me being able to print on the Dynamo Run button and print all the sheets of the project at once without worrying about the format is the most important.
This is why the MergePDFs node exists.

2 Likes

@Alban_de_Chasteigner
Yer, found that out spitting through all the different topics (see my previous post).
I wish all the topics without a solution would be deleted
(or when there is a solution they topics would be updated).
Would have saved me loads of time.
But thank you for your response tho :smile:.

Thanks a lot that helps out big time!

I want to use ur fix except Dynamo won’t let me install the package this is the error I get

Got it to work with a older version except now I can’t find the merge pdf node

Checked your response on another page and the file at: “C:\Users%USERNAME%\AppData\Roaming\Dynamo\Dynamo Revit\2.1\packages\Genius Loci\bin” isn’t blocked. Is it just because of the older version of the package?

You should be able to install the latest version of the package.
What version of Revit and Dynamo do you use ?
You may have already installed it and restarting Revit will correct this error.

The process for updating a package with the package manager is as follows :
Search the package,
Uninstall the package,


Close and restart Revit,
Install the updated package.

Yes I understand how to do it except even before I downloaded a later version it gave that error and even now when uninstalling and trying to install the newer version it gives the same error.

You can also download the package with https://dynamopackages.com/#, download the .zip file, rename it, and drop the unzipped file in C:\Users\%USERNAME%\AppData\Roaming\Dynamo\Dynamo Revit\2.0\packages

Not installing Packages from Dynamo, but downloading the ZIP from https://dynamopackages.com/
and then unzip it and place it in the (your) correct folder works better. At least for me it does.

Note
Rename the ZIP to the package + version you downloaded (instead of the default name).

1 Like

@bvs1982, I tried that I think the problem is that I’m currently working on Dynamo 1.3 and Revit 18.2. Guess I’m gonna need to update to be able to install the newest version of the Loci node.