List.FirstIndexOf could not work

As title, I’d like to integrate my model element base from the sequence with excel data.

However, I could not complete which I wish. So I might have some problem and hope get the hint at here…

My first guess is… the excel data must follow the " number or string", but even I re-modified in the excel file, it still cannot work.

Attach the not picture, and hope you could join this discussion.!

ShuoTao

Hi @Chiang_ShuoTao,

It returns -1 when it can’t find the item on the list.
You’ll need some kind of comparison, like “==” to find the equals of the ElementIds.
With that, you can filter what you need with a List.FilterByBoolMask :slight_smile:

Or like this, perhaps…

Thanks for quickly reply,

I will show an example with my original idea,

So, I don’t know why, the first not could not work but this one?

You might have a look at the types of your output (string, double, ElementId, etc).
Try to convert them to strings.

I tried the string from Object, however, it still not work…

PS.Simply explain,
the excel was from dynamo note, and reload to compare with the different before and after…

Can you share the .dyn file, RVT file and Excel file?

rather you have to convert your excel outputs to a number
String.ToNumber
also, you can disable “ReadASstring” in your import excel

Solution

  1. Ensure the “ReadASstring” is “true”
  2. Change the Element.ID to string( String from Object)

The FirstIdexOf would be work!

Thanks everyone :smile:

1 Like