Insert cad bloc by coordinates excel


i can’t to insert cad bloc by dynamo
may be someone can help me ?

Hi @dr.hybride,

The Point.ByCoordinates node is returning null because there is nothing plugged into the List.GetItemAtIndex nodes.

hi MZjensen

thank for your help but i have juste forgetten to plug into the list.getiematindex when i take the picture but now it plugged and it still doesn’t work,

Hard to tell without a description of the warnings, but another thing I see is that there are no layer or block inputs for the BlockReference.Create node.

and the description of the warning Warning : asked to convert non convertible types, and you are right about the BlockReference.Create i just wanted to resolve the first problem before :slight_smile:

thank you

OK my guess is that you are trying to pass strings into the Point.ByCoordinates node instead of numbers (double). Change the “read as strings” input on the Excel import to be false instead of true.

Also, there will continue to be warnings if there are null values (eg. list index 7). You can remove those with List.Clean, or edit your Excel file to not have blank cells.



you are the best !!! it works now i will try to insert the cad bloc
if you come in france call me we will have a drink :wink:

thank you so much

1 Like

Can you please post the dyn file
Much thanks