Index of not working missing error

hello, i seem to be getting a weird error when trying to find indexes of items. It finds most of them fine, but this exact one. it cant seem to find it in this one instance, but it finds it for all the others? Is this a bug?

Check for trailing white-space in the string values?

Hello @Ewan_Opie hopefully you can help me because I am dead in the water due to this one issue. I tried trimming the white space at the end but there is still no luck. I even extracted the string and then searched the list independently for each missing one, and the list contains node can find it no problem so I dont understand what the issue is, but all of my get index of nodes seem to be exhibiting the same inability to find the same strings. What gives? is there a way to do this strictly in a code block?

@mix Can you post your .dyn?
With the Object.Types the same I cannot replicate the errors in the List.AllIndicesOf node…

1 Like

Well my object types match, but I am still getting an error message. However I did find this node that seems to work from Springs

1 Like