Import info from Excel? Data.ImportExcel operation Failed

Error: Data.ImportExcel operation failed :frowning_face: How can I import info from an Excel file??

I see that this topic has been covered. I am new at Dynamo and coding. Although, I tried the other threads’ suggestions I couldn’t find a solution. I would love your help.

I am following a Lynda tutorial on how to set up a project using Dynamo and an Excel file. It is supposed to create levels and later views on sheets based on the information in an Excel file.

The tutorial uses a node called Excel.ReadFromFile to import information from a specific worksheet in an excel file. Unfortunately I cannot find this node in Dynamo. So I used a similar node, Data.ImportExcel. The only difference between these nodes is that the Excel.ReacFromFile node does not contain an imput for showExcel.

I created the Dynamo script per the tutorial in every other way. Unfortunately, when I run the script the Data.ImportExcel operation fails. I am using Excel 2013 and the most current version of Dynamo in Revit 2019. I have tried saving the Excel file as a xlsx and xls file. Neither worked.

Why isn’t this node working in the same way the tutorial indicates? What can I fix to get my Excel information to be properly imported into my Dynamo script?


I have had better luck using the OOTB Excel file reader, Excel.ReadFromFile

How did you get that node? That is the exact node that the tutorial recommended, but I couldn’t find it.

i think Benjamin_Doty1 is using Dynamo Version 1.3 /2 and you are using 2.0

Thanks Lucifer,
What do you recommend to get the Data.ImportExcel node to work?
Is there a similar node (and/or package) that you recommend for importing Excel data into Dynamo?

what is the error?

Yes. I am using 1.3.3

Warning: Data.ImportExcel operation failed

As seen in the image above the Data.ImportExcel node failed. Thus I was not able to import any data from my Excel sheet.

I don’t seem to have a problem with 2.0.1 either

I see that yours is working. Do you have any idea why mine is not?

What version of Revit are you using?
What version of Excel are you using?
Is your Excel file saved as a .xlsx or .xls file?


did you try closing and run it again? mine is also working as expected

I’ve restarted my entire computer. Excel asked me to accept Microsoft agreement. I did. Then I restarted Dynamo and reran the script. Now it works!!!

Thanks Benjamin_Doty1 & lucifer for helping me problem solve.


Aaaaand I’m adding accepting the terms of use to the list of reasons Excel interop can fail…


Hi. This problem is occurring with me now. What you did, in detail? Please. I´m desasperate with this.
I´ve reinstaled the Revit/Dynamo, Excel is original reinstaled too… But, nothing is working. Thanks.

Hi! I faced the same problem yesterday. I solved it by uninstalling MS Office and installing it again from my Microsoft 365 account. You have to pay attention to the version of the Office (32 or 64 bits). It must be the same of your Windows. …

1 Like

How to Solve Problems?

anyone else can confirm this? Mine is not working and i just checked and mine excel is 32-bit, system is 64-bit… will post here if changing excel to 64-bit fixes.

Hi, were you able to resolve the issue after changing your excel to 64?

It did resolve the issue but my x32-bit macros for excel no longer work… there must be another workaround.

S. Y. Liu

I had the same issue, import excel failed. I realized that recently IT had a rough time installing MS Project, and probably had to reinstall Office, but likely did 32-bit. I had to uninstall MS 365 Apps AND MS Project separately before I could install 64-bit apps from my MS account from I didn’t need to restart or press special OK accept terms type thing, I just fired up Civil 3D and Dynamo and the node now works.

1 Like