Getting type instances from windows

Hi guys,

I’m having an big issue. I’m trying to extract data from a linked model.

First I select all windows from the linked model. Next I’m filtering this list to the windows that I need.


Then I’m trying to get the Width parameters from each window. The problem is that it is a instance parameter, so it returns null.

Can I workaround this problem with a costum node?

Thanks in advance!

You are connecting a value of “Type” parameter to element input. You should connect the linkElement like you did on node to value of getting Type value…

If you want to get Type parameters from linked model, you can do something like that:

Thanks, that worked.

Next problem I’m facing is that it’s making lines in the wrong direction.

I don’t know how to fix this. I tried to delete the vector.rotate but that won’t work.


Do you need bottom line of window or top?

The top window Line of the window

I don’t know how your window family is but you have to manipulate it:

window_top.dyn (47.8 KB)

Well, the problem is that I got it done with windows in a normal file. Now I’m linking in a file and I get information from that linked file. I don’t know why, but it places my lines 90 degrees rotated with the linked file.

So my question will be, how can I rotate a selection lines in my script?

Can I rotate all these Lines on the midpoint?

I checked your flow… the vectors were not correct…Check the dyn file please. but if you want to rotate a line it could be like that:

Many thanks @Deniz_Maral

This has made my script easier to understand and it works.

The last problem I’m having is the FamilyInstances.ByLine node from archilab. I have all the requirements to place the linebased family, but it turns yellow without a error.

The lines aren’t on the right height, but I’m following another step after it places the family. That’s why they are on the bottem of the window.

What says the error message? It can be a Type error… can you try Element.Level node from Clockwork?

At least it’s giving me 16 nulls, but i still doesn’t solves something.

The elevations from the linked element and my file are also correspondending

Do you have same elevations in your model? If yes, it had to work… make sure if you have same levels as in linked file…

I have no idea how this is possible


It is very weird. Can you try the FamilyInstance by curve from Clockwork?

Same error.

Can you check the Z vector of lines? It has to be 0 because it must be on XY plane…
and can you drop the family file here?

The start- and endpoint both have a Z-vector. The direction doesn’t have it.

As I can see, the Z values are already in correct position. So we can try to place them on level 0 with List.OfRepeatedItem and as amount 16… If that works we have to check levels again if not, there is a problem with Geometry…

I don’t understand how I can do that. What’s my start point here? The linebystartandendpoint?