GeniusLoci ExportIFC node has UserDefinedPropertySets option greyed out why

revit
python
dynamo

#1

Hi,

from the Genius loci package, there is the nice “Export IFC” node.
I was just wondering why options.AddOption(“ExportUserDefinedPsetsFileName”,“the filepath”) is greyed out?
I would like to use this function. Why does it have a hash?

2018-10-11%20(2)

Thanks in advance.


#2

Okey so i’ve been a bit bold and just removed the hash

I have set
options.AddOption(“ExportUserDefinedPsets”,“true”)
and used the following syntax in the previously hatched line:
options.AddOption(“GV_EMA_DefaultUserDefinedParameterSets_180905”,“T:\Projecttekenwerk\P37047\X-BIM\1 - Model GV\4 - SupportDocsFiles\User Defined Property Sets”)

Its not working.

Should i include file extension in the file name string?
Does the file path have to include the file name?

and how is the previously greyed out line ‘connected’ to the UserDefinedPset option? Right now it seems as they dont work together.

I will try to look up the answer in revit api docs. But if an answer here is faster then you’re welcome :slightly_smiling_face:


#3

Hi,

Just remove the # in the python script and replace "the filepath" by T:\Projecttekenwerk\P37047\X-BIM\1 - Model GV\4 - SupportDocsFiles\User Defined Property Sets\GV_EMA_DefaultUserDefinedParameterSets_180905.txt**

I don’t use usually this option so the # is here to inactive it.
Yes include the file name and the file extension.

options.AddOption('ExportUserDefinedPsets','true');
Replace false by true in this line.


#4

Thank you.

In this topic IFC Export by Dynamo : User Defined Property Set there is word of having to change backslash to double backslash or use formard slash.

Is this true or not necessary?


#5

Excuse me. I am seeing now that you showed in your code to use double backslash. You only didnt type it in the filepath to copy :wink: but thanks a lot, Alban!


#6

Worked. Thanks a lot!


#7

In python the backslash ( \ ) character is used to escape characters.
https://docs.python.org/2.0/ref/strings.html

You can use forward slash ‘/’ instead.

P.S : I typed double backslash \ \ but it appeared as simple backslash in the answer.