Floor.ByOutline w/ Floor Type vs Element Type

I’m working out how to create a roof by outline and I thought by understanding the Floor.ByOutline nodes I might make progress.

Since there isn’t a Roof Type node, I’ve been getting there getting the Element Type - RoofType and filter down from All Elements of Type. By python script isn’t working though so, to troubleshoot, I looked at the Floor.ByOutline node. This node works when I feed it a floor type directly from the Floor Types node but not when I feed it what I assumed would be the same thing using the Element Type approach.

Is there something different about the Floor Type node vs. the longer Element Type approach that is maybe causing the issue here as well as with roofs? Is there another approach to get the Roof Type?

What’s the error when you feed in the results of the “List.GetItemAtIndex” node instead of the “Floor Types” node? It may be that the list structure hasn’t been completely removed so you’re feeding a list of items into the node which expects a single element. I’m also curious to know if it works with a IDs to elements node as an input.

It appears to be the same which is why it’s odd. When I plug the output of the GetItem, Dynamo just spins and spins. I haven’t let it go to see what happens since I know it should be done in just few seconds.

I think I tried the ID to Element approach already but I’ll take another stab.

The “get item at index” method is working for me… :confounded:

Might be worth trying just those nodes in a separate graph on the same revit file, ignoring the actual desired input and other desired results of the graph. Do something super simple like draw a box way off in space to see if it’s something else in there that’s locking things up?

Maybe. It works fine, however, if I feed it the type from the Floor Types node.

I’ll try it anyway. Maybe it’s an install issue.

Thanks for looking at this with me!

More on this; it seems the fix I found on the forum for the issue with uneditable code blocks and python is what is causing the problem. I was having a problem with another python node so I reinstalled and all of a sudden the Element Type solution worked. No other changes but now I can’t edit my Python or code blocks!

edit – Working again - I think a recent reinstall of Dynamo undid the above-mentioned fix.

1 Like

Ugh… this is why I hate updating software… :unamused: