Family.DocumentAddParameter -> Sub-Transaction Error

Hello erfajo,

i used your Nodes a lot already, thanks for that.
I have again a problem with adding the shared parameters.
I added now a Interface and get the following error: “A sub-transaction can only be active in inside an open Transaction”. I already tried to add the “Passthrough” node from Clockwork after the Background open or on the other input nodes of your add parameter node… Same error.
What can i do? When i freeze the node and unfreeze it again after the inputs it works fine.

Thanks already for your help :slight_smile:

The node includes transaction manager in the code, so I do not understand why you should have that kind of problem. What version do you use of Orchid nodes?

what sounds really strange is that freeze should do anything. Could you please upload the graph and a dummy file I can test on?


my last try was now to add the Transaction.end node before the inputs of the AddSharedParameter Node.

This worked for me but i still dont know why it doesnt work without that,

Anyway i created a dummy file for your testing if you want to figure out the problem.
I use Dynamo 2.0.0 with Data-Shapes and of course Orchid Package 0.0.1 :slight_smile:
Revit Version 2017.2.

The Files i uploaded to Wetransfer. Just 3 empty families, a dummy shared parameter txt and the dyn file.

thanks and best regards gerhard

1 Like

I tested your file, using your Shared Parameter file. I isolated the problem so I only tested my node, and that works without any problems. However, I cant answer for the graph as such and the Data Shape nodes. By using Data Shape you involve the user to interact, I don’t know how I should suppose to interact, so I froze all that.

Try to test if the values you try to feed my node, is the proper type (eg. String etc.)

I did have some problems with one of your parameters, they are named the same -> “Height” … don’t have parameters with the same name!

Add_Shared_Parameter.dyn (133.3 KB)

By the way, the version 0.0.1 is only the placeholder version in the package manager, You need to download latest from my github. the version is currently 130.1.01 or 200.1.01

Hi, I’d like to follow this up with another fold to the solution. I found the same sub-transit action error when using the Parameter.Associate Node in a longer definition. The solution was two fold, I had to add the DataStream.Await so the family document followed after the element selection. I also had to add a transaction.End between the family document and the parameter.associate node. These forums were super helpful for figuring it out, so wanted to add to the collective knowledge.