Export to DWG with Genius Loci Export DWG in document

Hi,

I have put a graph together following other posts in the forum to export all sheets.
If i connect a node to Export setup i get error as shown, if i don’t connect anything to this input , will have no errors, but nothing happens ( no dwgs in the folder )

Hi,

We cannot help you with such few informations. We do not have access to your input, so we cannot say if the problem comes from what you are feeding the node.

As the error suggest it, you may are feeding a wrong type of input to the node. But again, no way to know…

You can try to contact the authour of the package, @Alban_de_Chasteigner.

Hope this helps,

1 Like

I have attached my graph for your info
The aim of this graph is to select a revit project, which will be opend in background and all the sheets exported to dwg.Export to DWG2.dyn (41.7 KB)
Sheets%20to%20DWG%202

Hi @Hoss,

Just create a list of an item with the ExportDWGSetting.
The list of ExportDWGSettings is useful when you export DWGs from multiple documents at once.

1 Like

Thank you very much, its all working now

Hi @Alban_de_Chasteigner,

Sorry for replying back under this post, I got similar issue.
I’m just wondering if it works for getting DWG from couple of projects in the background?
I tried, but it only creates DWG from one of the projects.
I think the problem is with Export set up. the list is empty, but i can’t find my mistake.
I appreciate if you could have a look to see what the problem is.
Also, I’m just wondering from what package I can get “PassThrough” node.

Thanks much!

Hi Eli,

PassThrough comes from the great package Clockwork.
The ExportSetup input is optional so the issue doesn’t come from that.

If the Revit files are localized on BIM 360 or OneDrive, it could be the problem.
When I watch your screenshot, the Sheets and ExportDWGSettings aren’t found in your Revit Files.

Hi @Alban_de_Chasteigner,

Thanks much for your help :slight_smile: .

I kept trying and the issue is when I give a directory with only one Revit file, the script works perfect (I did tried it for the files in here). However, if I give a directory with more than one Revit file, it creates only dwg from one of them. I give directory from my local drive.
I can’t figure out what the problem is. I give similar script to read directory for my other scripts.

I really appreciate if you could have a look.

Thanks much
image