Dynaworks troubles

Hey, I am having some troubles using the Dynaworks package.

The problem is that the node ClashDetection.GetClashTests fails, as seen on the image below:

I have tried setting the “Visible” input to true instead of false, but that doesn’t fix the problem.

The only way I can get a working workflow, is by manually adding a clash test in Navisworks and then continue with the workflow in Dynamo, and to me, that seems a bit foolish…

I am using Dynamo 1.2.3 and have tried the Dynaworks17 and Dynaworks18 packages.

Any help is much appreciated.

  • Kristian

Have you defined clash tests in that file? This looks like you are exporting and trying to read at the same time.To my understanding that stuff needs defined in the navisworks file first.

But you’re trying to get the Clash Tests in your model… if no tests have been setup there’s nothing to return.

1 Like

So do you know of a way to export a Revit view and automatically perform a clash test in Navisworks?
Or should I start another topic on that?

Thx for the fast reply!

I don’t think Dynaworks has nodes for that. It might be possible from the API but I’d be a little surprised if it was readily available and just not included in the Dynaworks package. You’re probably better off creating the Clash Tests in Navisworks.

1 Like

Or running the clash tests directly in Revit.

I have already tried doing that through Dynamo, but it is not working properly unfortunately.

The company I am working at is trying to set up some sort of Block-Chain workflow wit our subcontractors, which means that we want to automate as much as possible, therefore we need something that works every time a new model is sent to us.

You can import/export clash tests and rules in Navisworks. Just set up “template” tests and rules and load them into any new project you get.

Which did you fail on? Running the intersection checker directly in Revit via Dynamo or creating the Navisworks tests?

@JacobSmall The Revit intersection checker.

@Nick_Boyts, thanks for the idea, it worked perfectly!