Dimension By References giving Null output

I’m trying to dimension an structural framing element using two references from the element but the Dimension by references node ìs giving null as output.

Can someone help me?

Flatten the ref list?

No, this time it’s giving me the null output twice

Have you installed the correct version of the IronPython 2.7 package? Check the Genius Loci package description for more info.

I have installed IronPython2.7 2.5.0 as is requested in the packege description but that doesn’t seem to be the problem.

Like need you to post the graph and a sample .rvt file to run it on. Alternatively you can pull the custom code out of the custom node and try running it in canvas to see if an error is exposed.

(See above for the project i’m working in and bellow the script i’m working on)
Dimensioning By references.dyn (50.2 KB)

Thank you in advance for reviewing my Dynamo script. The intention is to run the script in a cross-section of the foundation beam to generate dimension lines. I myself use detail view ‘12’. Please run the script in view 12 to ensure that the active view is correct

Hi @1034061RDHJ9 ,

The problem is about your dimension type. Try to use another one since for this one it says it is not a linear dimension type(even though it doesn’t look like that in Revit). I tried with another one but you may have other issues with references:

Hello @1034061RDHJ9 could something here work for you…


You were right, I retrieved the wrong dimension type. Even though I fixed this I still get a null output after running the scrip.

As you said this could be an issue with the references, but do you have any suggestions on how I could fix this?

Thanks again for reviewing my script but I still seem to be getting null outputs after retrieving the refences in the way you suggested.

Do you have any idea as to why that is? Could there be something wrong with my structural beam?

I tried on your sample and work…be sure you have dynamoironpython package 2.7 Ver 2.5 installed as well

Yes I have this package installed

not sure then, ihave just tried again 0n view 12 and works…try as here

test dim.dyn (38.5 KB)

and be sure your genius loci is the latest one