Custom Node input var[]...[] to infinity and beyond!

Can anybody explain to me why several of my custom nodes add another var to their input field every time I restart dynamo? For example, here is one I just opened. Blank graph, just this node.

Here it is again, same situation, after closing and restarting dynamo once.

The functionality of the node does not seem to be affected, but as you can imagine, after a week of developing tools with it, they can become rather… distracting. Any ideas as to what is causing this and how I can avoid it?

Hi @L-Vettz

Remove spaces from inputs and you should be fine:



@L-Vettz this looks like a bug - what version of dynamo are you using, can you please report it here:

As far as I know “Var” means a variety in type of input you are passing to the node.
In other words you are not specific with the input data type.
For instance your select model elements input field here MAY get input of other data types say a number and tries to execute the node,
I believe you should just type elements in the inputs and sellect the suggestion that comes in green color.
Hope this is the problem,Not sure though.

@Kulkul that didn’t work.

Now it is just adding onto the one after the spaces.

Here is the internal structure of this node (showing the same problem), however the duplication issue is not limited to this particular node.

@Michael_Kirschner2 I am on V2.0.2.

@L-Vettz could you please drop custom node here?

And also i told to remove spaces between words, write one word SelectedModelElements and so on…

1 Like


I think you have to delete the spaces in the name of the variables : words appearing in blue isn’t normal.
Also, have you tried defining yourself the type of your variables (i.e. replacing var[]...[] by a more pertinent type) ?

as recommended please try this without spaces in your symbol names (the string before the : )


Thanks. I misunderstood when you said remove the spaces. I thought you meant the “…” in the Var.

Removing them from the input name like you showed in your first screenshot seems to have solved the problem.

1 Like

I’ve tracked this internally as DYN-972