Creating solids between surfaces

Hello everyone, how you doing?

I’m trying to create a bunch of solids using the node TinSurfaceExtensions.CreateSolidAtSurface, like hundreds of them, my workflow right now consists in getting a big terrain surface and A LOT of smaller section surfaces (lets say i got N) i have, get the border of the smaller ones, crop the big one by these borders (giving me new N surfaces), and extracting the solids between each of these groups with the refered node. But i’m facing two problems:

1st) Some of the solids aren’t created, I even tried to create these one by one, but it simply dont work here

2nd) Some of the surfaces generate random solids, with holes in them, inside the boundarys of the surfaces, and when i go look at this solids index in dynamo, it says it generated 2 or more solids at this index (and that means I got more than N solids).

Any ideas? I’ll upload some screenshots and my .dyn as soon as my civil3D unfreeze

It seems like this step is unnecessary? You could just set the lacing to Longest on the TinSurfaceExtensions.CreateSolidAtSurface node. So the input for ‘surface’ is the big terrain surface (a single item) and then the input for ‘bottomSurface’ is a list of all the smaller surfaces.

1 Like

When i try to do this, it simply doesnt create any solid at all! even if I try to make just 1 solid, it will never be created. And I’m not even using a complex cloudpoint topographic surface, it’s just a simple one based on grade lines… I Really dont know whats happening

Does it work to do it through the normal way in C3D?

No, it doesnt, just tested and my C3D always crash if I try to do it through the normal way…

Tried to recover the file and audit it, and it gives no error… What you think? What I find weirdest is that i still can create some solids through my workflow, even with this errors

Some news:

When I delete some surfaces, it will let me make a solid through the normal way, but when I try to create a second one, my civil crashes again…

image

This is what i’m getting every crash

Can you share the files?

BuggedFile.dwg (2.6 MB)

thanks in advance

So, any ideas?

Sorry @guilhermeJHXAW, I’m not seeing the same issues. It took a very long time, but it didn’t crash. You could try breaking up the computation into groups of surfaces so that you have some intermediate break points instead of trying to do everything in one run.

@mzjensen sorry for the late reply, this project was on hold for some time…

And now that i’m back at it, I could solve the problem in just minutes, so if anyone has the same question:

When you create a volumetric surface between 2 any other surfaces, and you try to extract that solid, the prompt to create solids won’t have any parameter unlock to you modify, so you just click at “Create solid”, and the solid I was trying to achieve (between my two surfaces, the “volume solid”) is created automatically!

So this can be considered solved, now i’m going to open a topic to discover how to batch create volumetric surfaces via dynamo!

Thanks a lot guys