Clockwork Passthrough node doesn't work

Hi,

Im using the Passthrough node from clockwork but the option doesn’t work.
Is there something wrong in my script?
(there is no error the wait for doesn’t work)

What doesnt work or what should it do? and what is your input for the wait for?

It’s now difficult to give a solution from this picture.

@hugo.paalman thank you for youre reply

In my script I want to calculate the length of my pipes and pipe fittings. First I filter by system name and then by Section. The pipe fittings do not have a section, so I instruct the script to fill in the section of the connected pipes.

The intention is that the script first fills in the section and then starts filtering on Section (see part in gray)

When I run the script, it fills in the value of the section but the length of it is not included

Move the Passthrough Node before you start your Grey Group, just so it’s more clear when to execute which chapter.

Also, you’re pushing 2 values into the same parameter in 1 element in your Pink Group, resulting in the duplicate list, as shown before, something like a UniqueItem node there would solve that problem.

In the example I’ve done the same as you and made a new Section Parameter for Fittings, Having 2 different parameters in the same project with the same name will probably give you trouble later, so I would name that parameter differently (maybe also push that new one into pipes and push all the Section Data there?), having 2 parameters will make the script more complicated, having to query each element based on it’s Category in a different way.

Also, this logic is still failing on T-fittings. So you need to filter those out earlier.

As a general remark, study up on List Management, and what nested lists do and mean, you complicated matters in your screenshot by having list-layers that are not necessary.

@Bjorn_Keulemans1

Thanks again, I filtered out the tees at the end with i! “” Codeblock.

I tried what you said here but I get the following message.
The purpose of the script is to take the length up to and including the t-pieces and after a t-piece or diameter change.

Is this what you mean by double parameter?

Can be. I would avoid doubling up on BuiltIn parameters with a custom one with the same name on principle.

The Flatten Node is also grey, so that output could also be something not expected. Also no clue if you’re feeding the right elements, not enough info from such a small snippet.

1 Like

Dynamo script.dyn (20.8 KB)

Maybe you can see it here? Is the intention clear?

You disabled the Default value on the second input on the Flatten Node (right mouse button), the Node then has incomplete input and cannot work, so everything downstream is failing.

Your end filtering with the != code block is also wrong:
*You were comparing a list with an empty string ("") so the result would always be true
*Even if you were comparing the data in the list with the != function you are comparing a number (Length) with a String. so the result would also always be true.

I changed the test situation so you can test on multiple systems, otherwise your pipe (fitting) data is on a different level if there is no nested system level in your list.

@Bjorn_Keulemans1 Thank you very much! I’m sorry, i’m new with dynamo.

I don’t understand what you mean with this, i press the right mouse button. What’s next?
Knipsel

right click om “amt” in the Node, you disabled the Default Value by accident.

2019-06-27_1523

Hmm, I can’t click on it…
I have version 1.3

Specific reason for sticking with 1.3?

There is also a Flatten node with only 1 input. Search for a bit, do some troubleshooting, that is about 80% of what scripting/(visual)programming is.

Or just use the default value of -1.

1 Like

Thanks for your response. No there is no specific reason for this. Dynamo is on the server that is the reason for the version. The script does the same as before, the moment I use the play button twice, the value is entered correctly.

Sounds like your Passthrough node still isn’t in the right place. Have your graph run through all of part one, then add the Passthrough node, then continue with the second part.

@Nick_Boyts at what place?

Hard to tell without seeing your whole graph, but that looks like it would be about right. However, your passthrough input is taking all the selected elements after you just filtered them. Is that what you want?

@Nick_Boyts Yes, that’s right, the section parameter is entered at the bends, which is the same as the connected pipes. the “section” changes as soon as a T-piece arrives or if the diameter changes. I can then fill in the length of all connected pipes

Over here the script:

Nieuw.dyn (18.7 KB)

This isn’t exactly what you’re trying to do but it’s a similar process and it seems to be working for me.


I don’t think the passthrough node is even necessary to be honest. Once you filter your elements by system and apply the section number to your fittings you should be able to just continue using the same list of elements. The passthrough node is to help non-linear graphs run in a specific order, but you should be able to make yours linear.

I think the script gives problems because I created a Section parameter and this is also a revit parameter. if I do “play” twice, the script works as it should. I’m too precise :slight_smile: