Civil 3D Drainage Input Using Dynamo

Hi

I’m new to Dynamo. I’m trying to input an existing drainage network into Dynamo and add some automation functions for pit rotation.

I was stuck at the first step which is to import and display the network in Dynamo work space. Please refer to below image for details:

After running the script, nothing showed in the Dynamo work space (not even a point). Could someone please let me know how can I display the points and structures in Dynamo space? Thanks.

Ryan

1 Like

@ryan.xuCZYAS can you select the node that extracts the Structure Solids, swtich to the 3D background and click on zoom view?

Hi Paolo

Thanks for your prompt reply.

I selected the node ‘Structure.Solid’ - went to 3d view - clicked zoom to fit, but nothing displayed. Please refer to below images:

Any suggestions?

Regards

Ryan

can you share the dataset? I see you have 2 networks, could if be that they are very far apart?

Sure Paolo.

Please find below link for the cad and dynamo files (sorry I can’t upload files as a new user).

We just have one network and the elements are not far apart. Thanks.

Regards

Ryan

Ryan,

Paolo is correct. I went into the civil 3d and opened the prospector. You have two storm drainage networks in your drawing. “Test” network is quite far away from your actual network. Once I deleted the test network, ran the dynamo script, and zoomed to the solids in the 3d view the network appeared. You can select a network regardless of it’s position by selecting it from the prospector. Delete the incorrect network and proceed.

Hope this helps,

Shaun

Hi Shaun

Thanks your reply. Sorry to confuse you about having two networks in the cad file - I deleted the test network after Paolo’s reply, but forgot to save that down before sharing out…

I double checked and deleted the ‘Test’ Network, saved down and restarted cad. Then I went back in c3d/Dynamo and ran the script. Please refer to below image which shows that I have one network:

I then selected the ‘Structure.solid’ node - went to 3d view then clicked ’ zoom to fit’, but still nothing displayed.

I have updated the link for the cad and dynamo files:

Not sure if there is anything that I missed? I have been using Dynamo version 2.4 downloaded from autodesk account, and I didn’t touch any setting. Thanks a lot.

Regards

Ryan

I think that there is something else going on because the Dynamo file was in the correct position already. Can you see other geometry objects in general? otherwise it might be an issue with your graphic card.

Hi Paolo

I can’t see any geometry objects. Could this be related to my unit setting?

I have been using extra large settings as recommended. Perhaps this could cause the issue?

My device is a half-year old HP z book I5 G5. A lot of my colleagues are using the same model and I haven’t heard anyone had the same issue before…

Thanks for your responses over the weekend.

Regards

Ryan

Hi, in general, never change the settings of the geometry scaling, keep them on Medium even if you have the warnings. In this particular instance though the geometry scaling is not affecting the results.
It could be related to a graphic card driver and not the hardware.

Agreed,

Since there is no problem on our end I can only imagine it’s driver, install, or setting issue. Only thing I can think of is possibly trying to save your C3D profile and then going back to the default civil 3d profile and trying that? Or look for a setting reset within dynamo. I also believe civil 3d 2021 has become available for download, perhaps it would be a good time to upgrade if you need to do a fresh install.

Sorry I can’t be more help,
Shaun

@ryan.xuCZYAS. I recommend checking your laptop to see if it has dual video cards. It sounds like the wrong video card is being selected when Civil 3D is starting up. The following AKN article provide guidance on how to configure Autodesk software to use high performance graphics.

Regards,

Morgan.