BUG: Split curve with parameter or with points removes curves from polycurve + work around

As the title says split curve with parameter or with points removes curve segments from polycurve that are not used from the end. I have been working though workarounds to fix this bug for almost an hour or so including matching curve directions, before i make the polycurve, the works. Until i searched in the Git hub page and found it an old bug that will has again not been fixed but has been closed as for some crazy reason geometry bugs are not on the roadmap it seems.

The Answer / Workaround! is to include the End point of your polycurve in you list of points so it returns the last segments of the polycurve. See below

Input: Polycurve > Intersect with planes and split curve. Standard work flow. YES!

Output: Missing last arc segment of polycurve as split command does not intersect it but it does give you the first arc that does not intersect the point either… This it a BUG!!! not a feature!

Workaround: Add end point of polycurve to points list and it will return the last segment as expected

For those interested here is the original bug report on Git hub that should be still open or solved and closed

1 Like

I have had the exact same problem!
I solved it by recreating my lines by using the node Line by Start and Endpoint :slight_smile: