Assigned ASHRAE table fitting?

Dear Experts,
I want to check if any duct fitting type (F.example: SD5-10) from ASRHAE table have been assigned to specific duct fitting?
Is it possible using dynamo or python? :roll_eyes:

No any solution? :disappointed:


There are quite a few of us happy to help, unfortunately I’m not sure how many are from an M&E background… So to help the architects among us, would you mind posting a stripped down rvt file and describing a bit more of the problem?

At first glance it looks very possible!



Thanks Mark.
I am sharing sample revit and screenshots to explain my problem:

As you can see one of duct fitting have ASHRAE fitting assigned (First picture) automaticly by the revit.
However the second fitting no any ASHRAE fitting assigned(“No ashrae table applicable…”). I want to check all duct fittings in my project and seperate all fitting which is “No ASHRAE table applicable” (second picture).

Revit file:

Apologies, I’m on Revit 2018 here, but speculatively perhaps this is a simple solution that works for you?

Assuming that what you are after are the Elements which have Empty Loss Method Settings…

Hope that helps,


Dear Mark,
Thank you very much for your time. However it is not worked. :cry: It is giving empty value for all. However, ASHRAE assigned to one of fitting.
I am sharing revit file:
And dynamo script:
Deneme.dyn (7.4 KB)

As you can see i have two takeoff duct fitting in the revit model. Revit program automaticly assigned Duct fitting ED5-3 for the one of them however another fitting is “No ashrae table applicable.” But the method you wrote is not seperating this two fittings and giving me false value for both of duct.

Hey, apologies, but it’s still a 2019 file… if you could send me a link I’ll do it in 2018, but I don’t know how to make a duct fitting able to have the ashrae table applicable…

This will hopefully be part of the solution… I’ll have a look tomorrow…

Edit: I can translate the first part to Python, but the second is losing me… Perhaps @kennyb6 or @Jonathan.Olesen can help? :slight_smile:

The Parameter is not hosted on the element is the problem…


1 Like

Python did not worked for me. :disappointed_relieved: My python background is not good.
I hope you will achieved result :roll_eyes:
Thanks anyways for your effort.

First time hearing about AHRAE table fitting. I looked through @Mark.Ackerley’s link and I am lost too :joy: If I have some free time I can try the C# again but hopefully someone better can help first.


I would give this a read:

Personally I’ve never worked with ASHRAE tables either, but I think the post above will allow you to do what you seek :slight_smile:


Dear Experts,
Dont we have any solution for this task? :frowning:
May be using python?


Sorry, did you look at @Jonathan.Olesen’s link? It seems to have a few posts which would give you what you wanted?

Let us know if you can’t get them to work…