Archi_lab package "Parameter Group" node not working

Hello,

I’m very new to dynamo, but I’m working my way through some downloaded scripts to add parameters to a family… However, almost ALL of them require a node called Parameter Group (and/or Parameter Types) that the Archi_Lab package doesn’t seem to come with.
The package does come with Parameter Types/Groups nodes, but they don’t seem to be the ones that all these scripts are asking for, as the node still gives the error “Custom node definition is not loaded”.

currently, the dynamo script i’m using came from this post:

and I have all the packages required, including archi_lab, but yet that node always causes a problem.

I found a python script that I thought was going to do the same thing, from Konrad, but it doesn’t work.
Code for the Parameter Group node:

#Copyright(c) 2015, Konrad Sobon

@arch_laboratory, http://archi-lab.net

import clr
clr.AddReference(“ProtoGeometry”)
from Autodesk.DesignScript.Geometry import *

Import DocumentManager and TransactionManager

clr.AddReference(“RevitServices”)
import RevitServices
from RevitServices.Persistence import DocumentManager
from RevitServices.Transactions import TransactionManager

Import RevitAPI

clr.AddReference(“RevitAPI”)
import Autodesk
from Autodesk.Revit.DB import *
import System

#Assign your output to the OUT variable
OUT = System.Enum.GetValues(BuiltInParameterGroup)

I’m very stumped. Is this code not what I’m looking for? Why isn’t the original node working?

My ultimate goal is to add parameters to a large quantity of families which are already loaded into a file, although if they need to be in a folder, so be it. The parameters MUST be family parameters, not project parameters because these families will be used by customers outside of a template or existing project.

thanks,
Emily

Hi @emodderman ,
that node was replaced by a drop down node on the Archi-Lab Package. The drop down is pretty awesome, but it doesnt work in a worflow where you want the whole list of groups. That’s why I recreated it in the Data-Shapes package, you’ll find it here:

1 Like

Aha! great! that is wonderful. thank you!

Now, when i run this script, the notation/grouping in the script seems to imply that when the user runs this script through the dynamo player(?) it will prompt them with questions… i don’t get those prompts, so i still get errors since there is now no data to be used by the script…
i’m using dynamo 1.3… is this a problem?

Hi @emodderman

Could you please show us your graph image?

1 Like

Actually, I asked Data-Shapes and the issue has been solved.