2 identical lists. 1 crashes. 1 doesnt

Hi,

I am trying to duplicate my default 3D view a number of times, and name the duplicates using a list.
I would like to derive the names for the duplicated views from a list of exisiting values of a specific family parameter. But when I do this, Dynamo and Revit crash.
To compare, I created a test list with the exact same strings. And then there is no crash.
Why is this happening? What can I do to use method 1?

Many thanks in advance.

Hi @jnoordzij
Try adding a list count and cycle nodes. I think you are running into a problem of different length lists.
The cycle will give you a list of your 3D view you’d like to duplicate, based on how many names you pull.

Hope this helps!

1 Like

Thanks for the suggestion, but it still crashes (when using the list from parameter values).

But what can be the difference between the two lists mentioned in post 1? They are both lists of strings. They are identical. Arent they? Why does 1 work and the other doesnt?

Hi @jnoordzij

Remove lacing at View.Duplicate node.

1 Like

Thanks, but still crashes. :frowning:

what can be the reason that the list from ListCreate works, and the list from Parameter Values crashes? I dont get it. The lists are identical, and they are used in exactly the same way at input for ViewDuplicate.

@jnoordzij

my knowledge is far more limited than many people in this forum. However I’ve found several errors that make no sense at all like using the same parameter from one node works and nor for another, or Revit showing an error that " ( " character is not allowed in view names while doing exactly the same with a different approach allows to rename a view using " ( " with dynamo…

If you’re totally sure the lists are identical, then I’d suggest blaming dynamo and trying another approach (nodes, etc) :smiley:

1 Like

Do you happen to know what that parameters storage type is? Since we know the list of strings is working correctly, might be worth trying a String from Object node after your final list of parameter values.

1 Like

@dana.g Thanks for the suggestion, I like the idea. I tried using Strings From Object before input at ViewDuplicate but still, no result. Still crashes. And no, I do not know the parameters storage type… any idea how i can find that?

Something curious. I just took a read at this topic and I rebuilt the proposed .dyn by @awilliams. Same thing happened as in this topic: Dynamo crashing :frowning: . Could it be something bigger, maybe a re-install of my packages needed? I would like to avoid this measure, so if any other ideas for fixing the above pop up, it’d still be very welcome to hear them.

The only reason I can think of as to why the manually created list works and the parameter values don’t, is that the View.ViewDuplicate node is starting to run at the same time the Element.GetParameterValueByName node is running. So when it is a manually created list, the View.Duplicate will work correctly because those values are already there… not sure though.

Try using a Passthrough (Clockwork package, or a code block as shown in image below) - this will make it so the View.Duplicate node doesn’t receive the view to duplicate until the parameter values are available:

image

2 Likes

Also try replacing the view.duplicate nodes with a new one. What Dynamo and Revit versions are you using?

Thank you @awilliams for the suggestion. I tried the Passthrough node, but it still crashes.

Also Thank you @JacobSmall. I replaced the view.duplicate node with a new one. Still crashes. I am using Revit 2017 and Dynamo 1.2.0.

I was thinking about trying other view duplicate nodes. But 1) it should not be necessary, and 2) none of them seem to be able to duplicate a view multiple times and rename them :frowning: .

Also here is a download link for those who want to check the .dyn and revit.

https://we.tl/efejWcCHWx

Sure thing! (see below for a crude description/process)
This is using the RevitLookup addin, if you don’t have this installed yet, I’d highly recommend it going forward in learning the nitty-gritty of Dynamo and Revit itself.

At the moment, I’m fairly stuck with the initial question at hand, but if/when I think of anything I’ll report back.
One thing we haven’t tried yet is upgrading to latest version - Dynamo 1.3.2

1 Like