Volume


#1


Hi!
Why does it not recognize the “Volume” parameter?


#2

Not sure, I’d think it should give a warning for that. If I’m correct, I’m guessing there is a warning somewhere, where is it?


#3

There is not a warning, but “null” values in the “watch” window.


#4

I can see that, but the yellow text seems to imply there’s a warning somewhere.


#5

Put Node Element.parameters after Element.ElementType Node then put Watch Node

Then you can see Volume is not in a list.


#6

Thank’s. It was the solution.
But why it does not work in this case?


#7


the nodes work like this


#8

Volume is most likely an instance parameter. You are checking the ElementType which only has access to the type parameters. Use All Elements of Category as your input instead of ElementType.


#9

You need change parameter name “Volume” ( V is Caps Lock)


#10

This is the reason. By calling the element types you’re opening the element type dialog box in Revit, which doesn’t have a volume parameter as every instance of the floor has a different shape, so the volume must vary.