Revit 2022, System.IO.FileLoadException with no packages loaded!

I’ve been running Revit 2022/Dynamo 2.12.0.5650 for just this week, typically using older versions until a project required it. Right out of the box I started getting a System.IO.FileLoadException

I don’t have any packages installed short of regenerative design, which it won’t let me remove.
I’ve been searching the forums for a fix for this, and there’s mention of updating, so I pulled the latest stable build down, and that’s even confusing! Do I just extract (using 7zip) over the top of the program files\dynamo\dynamo core files? It doesn’t tell you what to do after uncompressing! (Default 7zip location was just a subfolder in my \download directory!

As of this morning, my Export to Excel Nodes fail to work! They were literally working 12 hours ago, now I just get “Export to Excel failed.” and no additional errors. These are the same scripts that worked yesterday!

Any help would be greatly appreciated! I’m not having any results trying to search and search again.

Can’t figure out what’s going on, currently uninstalling 2022, but this is in 2018 even now.

Try disabling all your Revit add-ins for 2022, and see if that resolves conflict.

For the excel file, restart your CPU and then see if you can write to a brand new file on your desktop. If that works, try the existing file. This type of behavior often occurs when multiple excel instances are attempting to use the same file in the background, so one bad Dynamo session which launched excel but failed to close it can get you into this state.

Tried the restart and tried a new file, things are just getting worse!
image
Error came back saying dynamocore.dll could not be loaded!

Uninstalled all versions of Dynamo, reinstalling 2022 now, will report back!

Fresh reinstall of 2022, same error as original. All older versions of Dynamo have been uninstalled. File.Exception.IO error went away, but now all versions all installs of Dynamo have this node broken.


Ended up needing to uninstall and reinstall Office and it’s up and working again.
Sigh, total waste of about 4 hours today for literally nothing.

1 Like

for anyone running into this thread later - there are 3 orthogonal issues here.

  1. The restsharp conflict- currently, no known issues - it’s just a warning -we’re looking to align with Revit/Forge version (not related to excel).

  2. Updating dynamoRevit via the daily builds -don’t do this. Sol did a good writeup here about the sandbox builds and why you would use them - A new way to get Dynamo Sandbox - Dynamo BIM

  3. Excel issues - this sometimes has more to do with the required .net windows feature being turned off over and over again by some group policy or busted excel or office installer (.net programability). Reinstalling excel over and over is the only thing that seems to work - this is one reason we have added new openXML interop nodes that do not require excel to be installed to produce xlsx files.

4 Likes