PythonEvaluator.Evaluate operation failed with CPython

Hi Everyone,
I’m having trouble with the Python node in Dynamo on Revit 2023.1. Since yesterday, I get this error message whenever I try to use it:

I don’t know how to troubleshoot it. I even uninstalled and reinstalled Revit, but the issue persists. One thing I noticed is that the node works fine if I change the Python Engine version to IronPython 2, which I downloaded from a dedicated package.

Does anyone have any idea how to fix this issue and make the Python node work again with CPython?


What is it you’re trying to read?

If you’re trying to read from the internet you may not have the right permissions.

Nothing. The node contains only the default python template.

I’ve had that message, but only when I was trying to read something I hadn’t got access too.

Have you tried deleting everything inside the node and only putting something like

OUT = 1

I just tried having the node with only “OUT=1”, unfortunately didn’t solved the issue. I’m afraid that the “inaccessible data” is python itself. Would that make sense?
Would be amazing if someone knew a way to spot what these inaccessible elements are.

Looks as if there is an infosec blocker. Best to submit a ticket to Autodesk support.

I have the same problem. Revit 2024.2, Dynamo 2.19.3

From the ticket I opened with Autodesk resulted that it is a problem of compatibility with pyRevit and with edit permission of certain folders. Being administrator account in the computer would solve the issue but is of course not always a viable solution.

I’m having this same issue. Getting the error on the python template. I submitted a ticket as recommended. Did any of you find a solution?

Disable your add-ins and see if that resolves it.