Fire Dampers Placing

Hi, just a quick question, why those nodes doesnt insert in the duct the Fire Damper?

The script locate exactly where i want the fire dampers but they arent connected to the duct.

Thanks in advance


image

There are already a few posts on this topic, have you checked them out?




If that doesn’t help: what exactly are you feeding into the node?

1 Like

Hi! yes i’ve already checked them out.

Check this. Its an old script in this forum. Thanks in advance.

Everything seems to be set up correctly. Could you share your Fire Damper family with me?

Volume Control Damper_TVJ.rfa (588 KB)

Sure!

1 Like

Thanks. I noticed that the size of the family is a type parameter. The node is primarily set up to work with size parameters as instance parameters. Anyway I will look into it a bit more as there might be some other errors at play here.

3 Likes

Thanks, i’ll wait for any update.

So I did some checking and the node seems to work with your family if you remove a few lines in the python code, as described in this post: Automate placing Pipe Accessory (Valves)
Also it will not work if the shape of the duct is not the same shape as the fire damper (round fire dampers will not be placed on rectangular duct and vice versa).

While the node works if you remove the specified lines as described in the above post the result will probably still not be satifactory. This is because Revit will just connect the elements but will not place any transition pieces between the elements. So it will look something like this:


So you’d need to make sure you feed in the proper family type for every duct size.

In closing: the node is really set up to work with fittings and accessories that have their size parameters set through an instance parameter.

Thanks, very gratefully, i will try it.

1 Like

My graph works fine except when one duct segment (straight duct) crosses two walls. it just places the FD on the first intersection. any help would be appreciated.

Try to change @Listlevels/Lacing.

Could you also show the duct inputs?

This is my graph

I see: you are inputting a single duct, but 2 lists of points, that is why you are only getting a single fire damper: only the first list of points is handled. If you remove the ‘List.Chop’ then you should have a single list of 2 points if am not mistaken. Use that as input to create the 2 fire dampers in that single duct.

If I remove list.chop, it will remain the same result (still 2 lists of point and create one FD at first intersection point). If I add flatten node to make a single list as you wish, it will not create any FD.

I found the error. The node is setup to work with multiple ducts (assuming that is always the case, otherwise there’s not a lot of autmation going on). So it actually expects an extra level on the list of points. Like this:

Kind of dumb, I know, I might try and fix this if I have some time left.

Hi @T_Pover just concerning aobut the family type “issue” with your node, how can i get access to all duct size in DuctSizeSettings in order to make a dictionary to associate the correct Fire Damper Type?

I think is the easiest way to input all the Fire Dampers necessary on your Node.

If you have any other suggestion please let me know.

Thanks in advance.