FamilyInstance.ByPointAndLevel gives "empty" error

Hello everyone,

I was creating a script which reads an Excel-file into Dynamo but i am running into a quite weird problem. I am inputting all the correct information into the FamilyInstance.ByPointAndLevel node but i am getting an error which i have not seen before:

Help would be greatly appreciated!

Did you run this workflow, went back in Revit did an Undo, modify the graph and then try to run again? Sometimes the node will hold onto the data previously sent into it, so if you ran the workflow, did an undo, you need to clear the data so to speak in the family instance by point node simply disconnecting one of the inputs and running. This will clear up the data out of the model.

Also too, if the lists don’t need to be sub lists, I would recommend flattening your family type, point and level outputs going into the family instance by point node.

Hope this helps!

1 Like

Most likely the element that was created doesn’t exist anymore. As @patrick_podeyn stated, this could be from undoing their creation, or it could be due to the creation method you’re using. The family types you have selected may not use the “point and level” creation method.


Yes i think this was the problem, sometimes the graph worked fine but on other times it glitched out. I closed everything and did a clean run and it work perfectly

1 Like

Excellent! I’m glad it worked out!

Yeah, certain nodes that duplicate sheets or views, creation of families, and any other creation nodes need to be cleared out when you undo in Revit. How you do that is you disconnect a “fulfillment” input from the “creator” node and run it to clear it out.