Dynamo 2.12 confusing description of NodeAutocomplete new feature in getting started screen

When confronted with the getting started screen in Dynamo 2.12, the user is led to believe that to use this new node autocomplete feature, they have to Alt + left click on the input or output.

After some time trying to make it work and fruitless online searches for other people who might have had the issue of it not working, I found the solution when I went to the help button next to the setting that turns on this feature.

So, apparently one has to double click instead of Alt + click.

Also, NodeAutocomplete is not enabled by default as the first description claims. It is an experimental feature that is disabled by default.

Hope this helps other people caught in the same issue.

It’s certainly a nice feature, but it’s just sad to think that a exciting new feature isn’t working for you :slight_smile:

2 Likes

Thanks for catching this. :slight_smile: I’ve let the development team know.

Thank you for posting this @sed07 and we apologize for letting this one slip through… a little wake-up call to spend more time testing non-code items! :pray:

We caught this internally also, and have this work scheduled to go into Dynamo 2.13 (Our next release). In the meantime, the single-source-of-truth is the Learn More button on the Node Autocomplete feature.

CC @Qilong_Tang

Thanks for catching this, will fix for sure in 2.13 so ppl can all enjoy Node AutoComplete. Also I believe it is turned on for ppl who has not used Dynamo before, if user has previous versions of Dynamo installed, Dynamo 2.12 will inherit the preference setting which may put Node AutoComplete disabled by default. We will update our language.

1 Like