Concatenate not working

I’m trying to join two bits of data so I can write it to a parameter but for some reason the size is not acting like it’s text even though it’s a string. What and i doing wrong? I want it to read {5" Sleeve}

try set lacing to longest instead of auto, if that still doesnt solve your issue, try use codeblock with a+b+c,
a is the prefix, b is the separator, and c is the suffix

string0 is not a string - you’re passing in a list of string or string - try using getItemAtIndex 0 or change the level for that input.

The code block worked best given that I actually have multiple values that need combined. So thanks for that! Now my problem the number is being carried out 6 decimal places, I tried rounding from the Element.GetParameterValueByName, but those seem to be integers already so I’m not sure where the training zeros are coming from, and more importantly how to get rid of them.

just split the string by “.” and get the first item and pass that to the ‘a’ in the code block.

convert your values to string by using string from object node

Try using Springs.NumberToString node

Thank you all for your help! I got it working.