Change projection color of element

#1

Hi all,

I’m dazzled at this point. I have Plumbing Fixtures families in a linked model. Some are existing and some are new. They are all from the exact same family, and the installer ( installateur ) choose to set the difference between existing and new by filling in the Comments in the Identity Data with ’ bestaand’ and ‘eind 2019’. Also the Phase Created is set to those two options. I want that the new families appear in blue. So I made a filter that should change the Plumbing fixtures with the Comments parameter with ‘eind 2019’ to blue. It does for all Plumbing Fixtures families except for the toilets. It completely ignores this filter and I don’t understand why or how.

So I made a script that selected named elements in Dynamo to try to turn them in blue this way. But also this does not work. Any ideas on how to solve this issue?

thx in advance.

#3

The filter I used

#4

It might help others if you were to upload a stripped sample Revit file with the family and filter so that we can test options out. This problem seems very much tied to your specific toilet family if it is working on other families.

#5

I had a similar issue, and it turned out that the model part of the family was a nested family defined as a Generic Model. Changed it to the correct category, and the filter started working.

#6

I checked the family and all the components, also from the nested families, are in the right category.

1 Like
#7

Well it is not my model, the plumbing is from a linked file that is provided by the installer.

#8

Okay but we cannot help you without a file to test on. To ask us to make our own file that can replicate an unknown error and then try and solve it for you is too much.

See if you can create a bare bones model consisting of just the family or a similar family that has the same issue and the filters. You can copy a family from a linked file into the current project by tab-selecting the family and using the copy + paste aligned to same place tools within the Modify tab (do not try ctrl+c). Until then, it will be hard for anyone to find a solution.