Module 2 Issue - Marker Incorrect Orientation

I recently downloaded the 1.0 script from

An issue I found was that when placing a model line rectangle and running the script, one marker has the incorrect orientation. Similarly with some other polygon shapes.

Has anyone experienced issues like this happening?




G’day Mark,


I didn’t come across this problem while testing the script on model lines while unwrapping building elevations,does it only occur on small scales like this?


I can’t test at the moment but will have a look later and try to reproduce.




Interesting. I get similar results with this approach using room boundaries instead of model lines. I suspected it had something to do with the room bounding nature of walls but if it’s happening with Model Lines too then something else may be going on.

In your example it’s the elevation in the Y axis. In mine it’s in the X axis.wonder if there’s something in there too.

Jeremy, if you haven’t seen my post on the issue you might check it out here –

Hey guys,

Mark, I tried this as soon as I got home and don’t seem to get the same issue as shown below. I’m using Revit 2016 and the script only works on Dynamo 1.0

Greg, I’m not sure why that is occurring with walls, I built it mainly for facades so I haven’t tested with room layouts, yet. I suspect it may have something to do with the relationship between elevations and the walls… I will have to investigate the API a little further for that and maybe post up a module on it. In the meantime, you might be able to code something that flips the elevation if the target wall isn’t in the views direction. If you come across anything, please let me know.


I’m also coming across this problem, im using the “Room.Boundarys” node from clockwork and flattening it before feeding it into the definition. It seems to be 1 elevation out of every enclosure that points into the room center. Same happens when i use the select model lines workflow, 1 elevation marker out of each enclosure faces wrong direction (In a box, it always seems to be the right hand side elevation)

Thanks for this module Jeremy, its helped out tons in my office already!

Hey Alisder,

I was wondering if you’ve looked into this issue anymore. I am using the script for interior elevation creation also, with room boundary lines. I’ll be looking into it more today, but just wanted to touch base and see if you’ve made progress.

Automatic Elevations.dyn (44.7 KB)

has anyone fixed this issue yet?

I know it’s been a long time but I thought it would be better to revive the post than to create a new with the same issue.
Any light on this? I’m facing the same issue and it looks like it’s some random stuff going on.
Here I ran it twice, with and withoud crop view. When the view is cropped it works well.

And the weird part, it’s not working in other files.

Does anyone have any idea on what migth be affecting this?

EDIT: I’m running the script with wall location lines