Zero Touch Node - Convert to regular dynamo Package

Hi All,

i have a question regarding Zero touch node . One of our expert API Developer had developed a zero touch node , that we load into dynamo as usual with import library options & it all works fine. However whenever i send the script to an average user( Arch or BIM/Engineers) who are not familiar with using dynamo , it is a challenge for them to know how to install the dll. I already have proper packages set up according to the different dynamo version we have across our organization & user are now aware of installing it at backend via copying them to the dynamo directory (appdata/roaming/dynamo…)

However for the Zero touch node, that’s not the case & every user need to be told & showed how to import the dll /library. i was wondering is there any way the zero touch node could be packaged as regular dynamo package & that can work , post copying into the packages backend directory.

kindly let me know what could be the easiest solution. Thank you

Hi Erfajo,

Distribution of scripts or package is not the issue here as we have managed it via a common repo & it is working fine for us. Problem for me is the custom Zero touch node by the Inhouse developer-installation of it across each user in time consuming & need to show each one how to do it for each of dynamo versions. the developer has been busy with other projects & so haven’t had a chance to look at it or re develop at simpler to other c# dynamo packages . Hence i was wondering is there any way to compile them or convert them into regulars package? please note: i don’t come from coding background although i use dynamo extensively . i tried using custom node/ package export option from dynamo -obviously it did not work . So appreciate if i could get help me with some guidance on a workaround for this. Thanks

Maybe look into developing a basic batch script/x copy that can simply copy the files to the relevant locations for the users. It sounds like the developer should consider packaging it up into a local package eventually though.


Yea, totally agree on that one-not familiar with coding concepts although tried to learn them many times. In terms of installation of any apps, that is regulated & via Our Group IS policies- its difficult for me to try anything & even requesting for any other decompiler apps takes quite a bit of time. i would go with your suggestion of turning to the actual developer & ask him to redevelop the way regulars packages are, that seems to be easiest & efficient way. Thanks again for your insights.

Hi Gavin,

yes i have been trying to get the developer himself to fix the issue ,as i am sure he can get it done much efficiently & quicker. unfortunately he is busy with various other projects & this kind off is in the back log/to do list for some time now. But yeah i will have to constantly follow up /annoy him to get it sorted. Thanks

Responsible coders leave behind enough for someone to follow or they take ownership over their code if not I think. Best remind them of that.

1 Like

Packages > Publish New Package
Publish a Package > Name etc. > Add (dll) Files > Publish Locally

Can’t be sure, but might work for you.

1 Like

Hi Vikram,

that absolutely worked like a charm. Earlier i tried the same but was only adding the main DLL file & hence it probably did not work fine. This time i added all the files from the library & published locally as a package & it works.

Thank you so much.

1 Like