Weird Dynamo Player error

Someone at work kept getting an error in Dynamo Player saying Python node was incompatible.

I got her to reinstall the packages - still got the error. There was the 2.7 IronPython package in her folder.

Then I got her to open some scripts in actual Dynamo and they worked…

Then back to Player and it seemed to load the 2.7 Python files… And then it worked.

Any idea why it glitched?

Not sure, but perhaps the engine wasn’t reset all the way between installations. Can only guess though as we can’t reproduce the issue.