Value at index in list not working inside a function. Dynamo


The [index] part doesn’t seem to work in Dynamo as it returns a null.
The same script did work in Dynamo and returned the value at the index.

Is this something that needs fixing? I’d like that because I have scripts written in 2.5 that don’t work properly now. I can fix it with a workaround for now but it’s not fun. :confused:

Kind regards,
Tenzin Lungtok

Can you post a data set where this fails? I can’t reproduce.

Thank you for your response.

I’ve sent you a message including a link for the dataset. I’m adding this screenshot in case I’m missing something very obvious.

What do you get if you remove the index value?

Then it takes every item in the list.

Unable to reproduce the error myself, but you could try

Have you tried using the Node Curve.PointAtParameter instead of the Code Block?

Your suggested method does work.
Am I right in understanding that; Curve.PointAtParameter(listname[index],parameter) works fine for you?

I’ll wait for your professional advice and that of Mr. Jacob Small but I’m inclined to do the old uninstall and reinstall trick.

That would indeed be an solution if I were creating a new script. But I have older scripts that have been constructred using codeblock and direct designscript. The syntax seems to not work for me which causes some issues.
I’m hoping to solve the syntax issue rather than finding an alternate method so that I don’t have to edit the older scripts.

It does work for me

I tried to reproduce your issue with the version you mentioned in Dynamo Sandbox, but couldn’t. Reinstallation might help.