Refresh Element Type Info

Hello all,
I have a problem in one of my workspaces that makes it seem inconsistent when we run it multiple times in a model. The part that is causing issue for us is the Element Types, when retrieving “ViewSheet” and “ViewPlan”. After running subsequent times, I get outdated information that causes the workspace to be inconsistent when we run it.

I have searched similar, tried adding the Boolean check early in the workspace, tried changing the element type and then back. Nothing will get it to the current set of sheets in the model. I have all of my scripts/workspaces set up to work through Dyno toolbars for our users and would prefer that workflow. Any information on the subject would be helpful!


Use Sheet Category and AllElementsOfCategory and see if that works better.

Does this graph also modify the document? If so I would try using a transaction.end after that modification, and then ensure your collection sub graph runs after that using a passthrough.

1 Like

Hi Sean, Thanks for the response. Does not seem to work any differently, It yields the same list. This test project only has three sheets in it.

Michael, Yes, it creates views and sheets and does some naming all based on an excel import.

I haven’t used transaction.start / transaction.end, so I am not sure where that goes on the graph, but I tried adding it after a SetParameterByName that is near the end of the graph, does not seem to affect anything, I ran a couple times and I still get a collection of past sheets that do not exist in the model. Let me know if you have any other ideas on it, thanks!

without seeing your full graph it’s not possible to be sure, but you need to run your query nodes after you transact with the document.

1 Like

Have you checked for Placeholder sheets? If the graph lists those sheets, they are there somewhere. Maybe a linked model?

Yes, one would think they exist, but they are past sheets that have been deleted from the sample project. They were created by the routine earlier, then deleted and project saved. For some reason the graph still shows these sheets. It will add new sheets if I add them too, but these sheets will not go away.

Michael gave me some links to check out, I will hopefully get back to trying to figure these out soon, have to get back to other things for now.

sample model sheet schedule (no filters):

first run list:

run second time (adds recent sheets, old sheets STILL exist!)

I would suggest that you give us a full image of the graph with all result windows open and/or post the graph with a sample model. As @Michael_Kirschner2 points out we are running around blind without more information.

Have you checked for Placeholder sheets? If the graph lists those sheets, they are there somewhere. Maybe a linked model?

That was the problem, for some reason their template did not show the placeholder sheets in the sheet schedule until I added a row and removed it again, then it revealed the placeholders. Thanks so much for your recommendations!