Print to PDF doesn't work

Hello all. I’m trying to make a print to pdf graph but couldn’t male it work. I know there is a lot of topics on this issue and read a lot of them but none of my tests worked. On my last try I copied a graph posted by @Alban_de_Chasteigner here. Here is my last graph:

Does someone lnow what I’m doing wrong?

Hi @Gustavo_Bento_De_Me1,

It’s really hard to help you without seeing all the graph but I think it’s only a matter of lacing or list level.
Your Filepaths and PrintSettings are in the form of a list of list. For example, use a List.GetItemAtIndex or a Flatten to simplify your inputs.

Hi Alban, thank you for your attention. I’ve tried what you suggested and it still doesn’t works:

Also tried to use the flatten and get item at index nodes, but didn’t worked too. So i tried to change the lacing too longest and got 5 (which is the number of sheets I’m trying to print) nulls as a result:

So maybe the problem is with the elements I’m sending to print. Here is the rest of the graph:

The getparametervaluebyname node is used to read a file name parameter that we use in the office and generate the file names to be used in the pdf files.

You must use PrintSettings elements and not the Printsetting names.
There is a Print Settings node in archilab package.

PS : There was indeed an error in the picture in the link of your first post.

1 Like

Thank you very much Alban, it worked. I had already tried this but my archi-lab package was not up to date.