Populate Areas with combined Unit ID


#21

Once you filter out the bad, use the filtered elements to contain the the filtered elements into the rest of the string. Pardon my bad MS paint sketch lines…


#22

thanks Jacob,
the math node that you use have levels, I cannot find this node???
what am I missing?


#23

Read in here about List@Levels http://dynamoprimer.com/en/06_Designing-with-Lists/6-3_lists-of-lists.html
image


#24

Thanks,
I found it,
Jacob if I set the filter there the list do not include any area input, as the filter is taking area schemes
no idea why?


#25

No as I don’t have a file to work with - I’m basing all my input off of my own work and the images you’ve posted. Expand your previews and I can try to guide you along further.


#26

Project2.rvt (2.8 MB)


#27

Multiple areas.dyn (12.1 KB)


#28

file attached and graph
maaaaany thanks!!!


#29

You’re filtering the parameter value not the element. You need to use List.FilterByBoolMask on the elements.


#30

As @Nick_Boyts said, you’re filtering the wrong data. Your list of elements need to be the original list, not the area schemes.

I also didn’t have any “NIA” area types in the file you sent over, so everything was filtered out. Changing “NIA” to “GIA” or “Unit Area” kept some stuff in the filtered list.


#31

Thanks Jacob, NIA is not a type of Area is an Area scheme, Revit do not deal with this very well because these area schemes are not area parameters but family name??? weird!!!
I am going to try to filter the right list as Nick suggests and see if it works thanks!!!


#32

Sure, now the filter is working!!!


#33

Hello guys, thank you very much for your support, here is the graph just in case anyone fancy using it!!!
Your support make a difference!!!

Combined areas with similar Unit Id.dyn (14.3 KB)


#34

Gala you got it working! Please mark the correct post as the solution so others can find the right answer faster.