Placing RLs on Floors

Hi All,

I’m currently working on a script to place RLs at the centrepoint of all floors in a view. I’m using the ‘SpotElevation.ByPoint’ node from the Clockwork package to place the RLs.

I believe I’ve input everything correctly into the node, yet it returns null values when I run the script. You can see in the revit screenshot below that the centrepoints of the floor surfaces are identified, yet no RLs placed…

I’ve tried it in another project with several more floors, and when ran 2 RLs were placed but all the rest were missing. Can anybody shed some light on why this may be happening? Anybody had similar issues before?

Thanks in advance.

Script & Revit File attached.

DimensiongFile.rvt (1.3 MB)
Place RLs_V1.dyn (29.7 KB)

Tried your script and file, made it work after running the script in a 3D view first and went back to your floor plan.

(Changed it a bit as I don’t have all your packages installed)


Will try to get into why is this happening…


Hey @architectcoding

Thanks for your reply.

Are you getting the RLs to place on the floor plan after having run the script in a 3D view? I tried this on my end and the RLs were successfully placed when the script was run in a 3D view. I then returned to my floor plan view and ran the script again but still no RLs placed…

Appreciate the help.


I’ve realised that the view input is causing the issue.

I’ve got it working by switching out the nodes I previously had feeding a view into the ‘SpotElevation.ByPoint’ node with the ‘Springs.Doc.ActiveView’ node as shown below.

Not sure why this is cause they both appear to be outputting the exact same thing…?

It’s working in the test file I previously shared, but when I test run it in more complex projects I’m still missing most of the RLs…