Mouse Pan zooms

Just started seriously using 2.0 & I’m having a lot of troubles with my mouse.
As I’m trying to Pan around my graph by holding the mouse wheel down, it more often than not Zooms way out so my graph is a tiny dot.
Didn’t (and still don’t) have this problem in 1.3.x versions of Dynamo.
Is there a way to turn off or configure the Mouse Zoom?
I want to Zoom by rolling the mouse, not by holding it down.

In 1.3.3, under the View…Zoom. menu, I have Zoom In and Zoom out.
In 2.0, I have both options on the menu, but Zoom Out is grayed out.
DynamoZoom

Looks like you may need an update - can you confirm what version of dynamo you’re on?

I’m on 2.0.0
Is this fixed in 2.0.1?
I kind of hope so, but I kind of hope not, because I just finished Deploying Revit 2019 & Dynamo 2.0.0 to 90 users. :roll_eyes:

You should upgrade to test. 2.0.1 has been out for about 6 months - why did you choose to go with 2.0.0? Several updates and fixes in there make it worthwhile even if this doesn’t resolve it.

Nuts.
2.0.0 is what was in the Deployment I built from my original Autodesk download
Are you aware of any problems if I build the graphs in 2.0.1 & others run them in .0?

I can’t say I am aware of any issues, but the list of updates in 2.0.1 is pretty big.

http://dynamobim.org/hurray-for-hotfixes-revit-2019-0-1-and-dynamo-2-0-1-released/

As @Racel_Williams notes in that blog post:

Dynamo 2.0.1 has the following fixes:

  • Search works when special characters are used
  • Library communicates with browser when other Windows services are running
  • Comments for Input nodes in custom nodes are now saved to JSON
  • View blocks in custom nodes are serialized after editing and saving custom node properties
  • PolyCurve.ByJoinedCurves continues to work in 2.0. This node has also been updated with a new tolerance parameter.
  • File Path node is now compatible with Dynamo Player inputs.

You should also get Revit 2019.1 installed.

Sigh.
2.0.1 didn’t help my mouse problem, but I’m still going to have to revisit 90 desktops.
& Here I thought I was done.
I’ve stuck with 1.3.x all summer & fall, so I didn’t notice there was an update.

Ok. Was hoping that would be a magic bullet for you.

Side note: You may want to look into ways to update the installs more efficiently, but that’s a conversation for a different forum as Dynamo doesn’t allow that functionality. :slight_smile:

Is this performance issue on all graphs or only specific ones? Does it happen in both Dynamo Sandbox and Dynamo for Revit, or is it specific to only one environment?

I finally figured it out!
I have a Logitech M510 mouse. The wheel is one of those “tilty” wheels. It not only scrolls by spinning the wheel, but you can click down on the wheel.
AND you can tilt the wheel to the left or the right.
The “Tilt left” and “Tilt right” were set to Zoom.
So when I thought I was panning by holding the wheel down, I was actually tilting it to one side and Zooming.
I used the Logitech configuration options to set the left and right tilts ot “None” and now I’m happily panning around without tearing my hair out!