Model Space Missing - Laptop with Multiple Monitors

So, this doesn’t seem to be a new problem, but the solutions I have read from past forum posts have not worked… or have worked momentarily, and then the programs have all crashed.

Problem: When opening Dynamo (or Dynamo Sandbox), the Model Space is missing. There are no axes, or grids shown in the background.

Considerations: This is happening on two users machines, and they are both laptop users, who have docking stations as well as a pair of monitors they connect to. When they use dynamo while un-docked, the problem does not present itself. They are on Windows 10 Pro, and are using Revit 2018, and Dynamo 1.3.3.

Solutions Attempted: This isn’t an issue of the model space being zoomed out or oriented in a weird way that the grid is not visible. That has been checked.

  • We have updated the graphics Card drivers on the laptops.

  • We have one into the NVIDIA Control Panel and added Dynamo to the list of programs that use the Graphics Card, as well as assigning the card to both Dynamo and Revit.

  • We have rebooted after doing this, and tried again.

  • We have tried launching Revit and Dynamo while the laptop is un-docked, and then docking the laptop once Dynamo has properly opened (and Model space is properly shown). This last solution attempt seemed promising, however moments after docking, the programs both crash.

At this point I am stumped.
Does anyone know what might be causing this problem, or how else we might solve it?

Check the zoom ratio on the laptop vs the monitors.

I get where you are going with that - I will check with the users… But given that Revit has all sorts of glitchy problems if those settings don’t match, I can’t imagine that this would be the case… I would have already seen help requests from them for all their Revit issues.

Revit should work better than it has previously if all your updates are in place. I’ve seen lots of users have these mismatched and never have a complaint, even if it was done externally.

Also, the nvidea settings may toggle back to not using the descrete card once the system is docked - so check that again while you’re at it. I know I had to set mine repeatedly as a result.

Thanks Jacob - we’ll take a look.

Are you using a dock to connect the laptop to the monitors? We had this issue with dell display link USB D300 and USB-C D6000 docks. Neither would display the preview unless dynamo was started with the dock disconnected.

We switched to dell WD15 units which solved the issue.

1 Like

We use this one:
Targus Display Link Plug and Display
Universal USB3.0 DV1K-2K Compact Docking Station TAA
Model: DOCK121

But it is interesting to here that different docking stations could cause this error. Unfortunately, when we try starting dynamo while disconnected, and then connecting to the dock (an annoyance, but an acceptable one if it works) both of our users who have been having this problem have stated that their Dynamo then crashes almost immediately.

Jacob - the users displays were all set to 100% zoom (both the laptop and the dual monitors). Any other ideas? Dharman indicates it may be the docking station.

Could be the docking station, but that’s something I can’t get any insight on.

Can you try plugging directly into a monitor?