MEPover package - i have an issue with having no level parameter for duct accessories


Hi i used your package to add fire dampers in fire walls and it worked great so thank you for that!

but i did notice that the dampers placed didn’t have a level parameter, where as if i place the damper manually it does.

Because it hasn’t got a level parameter all the dampers are given a offset height from 0, even on upper floors. so it could be an issue when scheduling.

having blindly poked around inside the python script for the MEPFittingbypointandcurve is mentions Z values and nothing about levels…

do you know if this it is possible to add something in to give the the dampers/fittings the same reference level as the ducts that host them?

or any advice on how i can get the fittings to have the level parameter?



Hi Daniel,
Thanks for pointing this out. In the python code I had intented to query the level of the duct and use that to assign to the fittings. Turns out I was querying a wrong property. I fixed it in the node and uploaded a new version to the package manager.
With the updated node it should assign the fire damper to the same level as the duct.


thank you so much! @T_Pover didnt expect to wake up this morning and it would be working!

seems to be working perfectly now!:+1::+1:


sorry, @T_Pover that was a little premature.

it works perfectly on level 0, but if i add any ducts to say level 1, it associate the dampers to level 1 but the height is the duct at level 1 plus the height of level 0.

so all the ducts move up by 4m and there’s some disconnection and deletion warnings.

is it just me or is that happening for you too?

Hmm, seems like the entire node no longer works for me… I will have to check it out :frowning:

I made a small adjustment and updated the node again.
The method for placing families is kind of annoying in the way it treats offsets in relation to its hosted level. I think it is working now, but I have experienced odd behaviour on this before… so fingers crossed.

Thanks @T_Pover!

tested it out on a few floors and seems to be working perfectly now!

1 Like