MapFeature issue

Hi everyone!

I am carrying out a Dynamo script and the aim is to convert shapefile polygons into closed polycurves in order to extrude them as solid.

With one shapefile I did not have any issue with the process. I show one example:

If I try with another shapefile I receive the next warning from the node MapFeature.Geometry:

You may notice that in the Civil 3D model space, polygon coordinates are not far from the origin so it does not seem a range problem.

@Paolo_Emilio_Serra1 , as these are nodes from Civil3DToolkit, can you find at first glance the issue I am having? Polygon shapes are not quite complex either…

I attach files as well.
Test.dyn (47.8 KB) Test.dwg (911.9 KB)

Many thanks in advance,

Check to see the length of each edge in the shapes you are using in the DWG (explode and data extraction should give you a workable list). You may have very small lines in there which sometimes result from bad GIS data.

Hi @JacobSmall . Thank you for your reply.

I am not sure if I get what you´re saying… a Map Feature is an element impossible to explode within Civil 3D. If I select one polygon in the model and I execute the command “explode”, it does not affect the polygon so it is still a Map Feature.

Fyi, when invoking Paolo, be sure to attach the “Autodesk_Civil3DToolkit.log” from your Temp folder.

image

You can use MAPIMPORT in C3D workspace to import the GIS data instead of creating a map feature in Map3D; that way you can check the polygon that is created and see if there is a duplicate point perhaps. I opened the .dwg file but I don’t see the map feature, perhaps it is linked to the shp file you used?

2 Likes

Hi @KirkWM ,

The disadvantage of carrying it out with MAPIMPORT command is that you have a MPolygon identity that is not recognized within Dynamo or I did not get it. The advantage of MAPIMPORT is that attributes are in every element of the model space.

I have tried the Dynamo package called Dynamo GIS and I have achieved to import the geometries in Dynamo but no attributes are read. (OD:Test in properties tool).

Other path I have tried is to explode the shapefiles imported with MAPIMPORT but attributes disappear.

I attach the .SHP.

Kind regards,

I think that I have discovered where the issue comes from!

As you can see in the picture I attach, lengths are too small and always are the same in the same polygon. Coordinates in many vertexes are the same as well (few decimals are imported from shapefile). Units are in meters. Maybe, that is the reason why Dynamo always pops up a warning which says “Polycurves may be branching”, “Points are likely coincident” or only detect the polycurve with 1 curve.

Yep a this is what I was referring to. You may find that there are even smaller distances in some shapes. I saw some zero length lines within GIS data when I was putting my AU session together last year…

I recommend you test the polygons by exploding and attempting to bring the contents of that layer into Dynamo. I think you can get an edge count before and compare that to the line count after the fact via data extraction or other means (I am not a CAD expert).

There is a package I found useful for GIS data called Elk which read all properties in my testing - you may want to look at that as well.

2 Likes

Ok yeah, I just meant to do a test import using MAPIMPORT to look at the object in question to see if there were any quirks with the geometry. Glad you were able to find something :+1:

1 Like