Issue with List Output Showing 'Function' Instead of Values

Hi,

I’m trying to create a list, but I keep getting “function” as the output. Can anyone advise on what might be the problem here?

For context:

  • Item 0: Listing chainages along the alignment
  • Items 1 and 2: Calculated numeric values for the crossfall and longitudinal grade

Please note, I’m not using C3D data, so I’m unable to leverage the subassembly parameter nodes.

Thanks for your help!

The python node looks to have more inputs designed than input.

You will need to share the python.
Edit* i thought the list node was a python node… silly me

Try taking off items 3 and 4 off the list create function as it won’t work with missing inputs.

Hi,

Thanks for this. Removing the items worked for me however, I’ve now encountered another issue where the data has not outputted properly to excel. I’m assuming this is due to an error with the list levels. Any advice on how to resolve this?

Gotta have all 3 input lists to be the same list level so I 'd check that first.

Hi Kirk, thanks for this. I ended up flattening the data to have all lists at the same level and it worked fine then.