Ignore Index was out of Range Warning

My graph is doing the desired task but I do not want people to see this warning. How can I get rid of this warning?

Two ways:

  1. Using the node as a function, and applying that function to the data set. Simply disconnect the input from the List.FirstItem node, and wire that as the input to a Function.Apply node, and put the list of elements in as the argument input.

  2. Add a zero width string to the front of every list with a List.AddItemToFront node. Watch the list levels as you want to work with the lists at level 2. This will ensure all items have a list, and you’ll be grabbing the item you want so no need for the python node either.

1 Like
  1. Function.Apply does not seem to work on all lists.
  2. In second method, I would need to get second item from each sublists except the sublists having list.count 1. Any simpler process?

Sorry - may have responded before my brain was all the way on this morning - a bit jet lagged at the moment.

Use a List.Map instead of a Function.Apply on the first option.

And a List.AddItemToEnd with a List.First is the right combination for the padding of the lists in the second option.

1 Like

Thanks for sharing the image. Any idea to quickly do the same for Element.Name?

On the list map side, disconnect the function input. Wire that into a new Function.Compose node. Then add a second input to the function compose and connect an Element.Name into the second input. Then wire the function from the function.compose node into the List.Map node.

Not using the functions you are after, but this should work to illustrate the point:

1 Like

Thanks a lot. It’s working fine.

1 Like