Hp zbook 14 G2 with AMD M4100 GPU - Fail

When I start a new project in my Dynamo Revit add-in on my hp zbook 14 G2 mobile workstation (win 7 64 bit), Dynamo shows a solid black background on the second monitor. Moving Dynamo to the primary changes the background to solid white. I do not get the gray background with the 3D grid. Yes, my background preview is turned on. I assume this is an incompatibility with the on-board AMD M4100 GPU. I’m not a big fan of these zbooks or AMD at the moment.

Question 1: Is this something the Dynamo development team may address in future releases?

Question 2: In the meantime, what mobile workstation configuration is suggested?


Hi Steven,

I have a Zbook17 (W7,64bit) Intel i7 with Nvidia Quadro 4100M and it works great with Revit 2015, 2016 and Sandbox.

Good luck!



my nvidia graphics needed me to change the settings to always using the graphics card instead of integrated graphics or “auto”. I had the same problem you are describing and went away after changing the settings.

Hi All,

Another interesting facet of the Dynamo and AMD story, thanks to BreannaD:

“After several months of fighting with this on a Dell Precision 3510 with Switchable Graphics (Intel integrated and AMD GPU), I finally narrowed down our issue.
The solution, for us, was actually the OPPOSITE to what a lot of people are suggesting… We had to point Dynamo to use the Integrated Intel card, because it was the AMD card that was not displaying correctly!
So, in short, many people are suggesting to assign your Dynamo to “High Performance/Maximize Performance” in your GPU settings, but actually what we needed to do was select “Power Save/Low Performance”, which then points the program to the integrated card instead.
If anyone else has tried to point Dynamo to their nVidia/AMD card without avail, try doing the opposite. Worked for me.”