Filtering by Suffix all have the same ID

I’m filtering for all the dimensions that have a suffix,
but why do they all have the same id number?

You probably filtered their dimension type, which has one Id even if referenced more than one. Use the type to filter, but filter the original dimension instances.

1 Like

check dimension types.dyn (21.7 KB)

1 Like

Yes, thank you… that’s what wasn’t clicking.
Thanks for all your videos too!

1 Like

Most welcome :slight_smile:

1 Like

I failed to upload my screen shot, we’re getting the same list of ids,
but when I try to change the suffix I’m loosing something by the end, I’ve tried the levels and lacing a few different ways

It’s probably in my python,
I was expecting 42[0] to be false

Maybe your string looks like this: " CLR" or " CLR " instead of "CLR".

You could remove the whitespace or use the String.Contains node instead of the != node.
Let me know if that works.

PS: Using the String.Length node you can easily identify if whitespace is the problem.

that did help, I’ve tried so many variations that I was adding bugs, now I’m back to the original post. When I filter by Class I’m getting the Individual Elements, but once the Bool Mask looks for Suffix, they become the same.

Hi @TurtleWolfe .

It seems like 1 dimension is returning multiple suffixes, so the comparison afterwards doesn’t correspond correctly anymore.

For example: 41 | Dimension gives three different results so you’ll have to make sure the filter works by comparing all three results and returning a true/ false based upon them all as one boolean. (instead of 3 in this case)

Something like this should help you get further:

1 Like