FamilyType.ByGeometry - Category not found

Hello everyone,
I’m currently trying to build a Dynamo script but I’m having a problem with the FamilyType.ByGeometry function. This function creates a new family for each input geometry. My problem comes from the category I want to assign to it. I want it to be a Volume. I therefore indicate in the templatePath the path for using the metric Volume family. When launching the script, Dynamo reports the following problem: “FamilyType.ByGeometry operation failed. Category with name Volume not found”.
I’d like to point out that I’m launching the Dynamo plugin from a conceptual Family Volume window (I have to because I’m using functions that need to be in this environment).
Do you think this could be due to the window from which I’m launching the script? If not, does anyone have an idea for a workaround?
I’ll be in touch for more information on the problem.
Thanks to all

Open that template file in Revit and try to change the category to the given value. If that won’t work than you won’t be able to do this in Dynamo either.

Yes i did it with a generic model and that’s seems good. But i wrote a scipt that use only ConceptualMass → Metric Mass model …

Hmmm… Is Volume the localized category name for Conceptual Mass? If so what language?

Also what version of Revit are you in?

I don’t understand your first question.
It’s in French. In the templatesPath, i’ve got “…\Conceptual Mass → Metric Mass” (=Volume conceptuel → Volume métrique in French)

i work with @DYNAMO v.2.19.3 © 2023 Autodesk, Inc.

What categories are available for that template in the Revit UI? Screenshot is fine.

I cannot do a screenshoot. there are too many possible categories, it doesn’t fit in 1 capture. it would take dozens of them

Can you grab the section where ‘Volume’ shows up?


yess of course
the other category with Volume dont work

This is the Dynamo UI - i’m wondering what you see in Revit after starting a new family and attempting to change the category.

okay
aujourdhui7

maybe it’s a version problem 'cause someone else used my data and worked for him …

did it help you ? @jacob.small

Haven’t had a chance to check. Will attempt to do so later tonight or tomorrow.

okay tell me if you found something.
I don’t understand something. When i choose my category, the same error tells me that the category doesn’t exist (look my screenshoot above) (when i run the script directly in the revit project or in a family windows, i’ve the same error)