FamilyInstance.ByCoordinates Node uses Meters for coordinates By Default?


#1

I am using the FamilyInstance.ByCoordinates Node. It seems that it converts the XYZ coordinates to meters. I am not sure how to change this. Is there a way to switch this so the coordinates get converted to feet and inches? Or is there an Imperial version of this node? Any tips would be greatly appreciated. Thanks!!!


#2

A toggle to set the default units would be a welcomed addition!

As a workaround just port your coordinates through an equation, custom node, or code block reference to do the conversion . (just be sure to double check for rounding errors)

Convert Meters To Feet

 

Good Luck!


#3

Thanks for the advice! That worked pretty well for what I am doing now, but I really would like a more precise method.


#4

 

 

 

 

 

 

 

 

 

 

 

 

 

Following up in regard to the rounding issues, I would recommend adjusting the decimal in the equation.

Due to Revit’s incremental units being 1/256 the conversion was resulting in unclean dimensions with the 3.281 conversion . For example defining something as 4’-3 1/2" was translating to 4’3 129/256"

Also I noted that my current definition is set to decimal feet and withing this the “StructuralFraming.ColumnByCurve” node requires a decimal meter input, but the “StructuralFraming.BeamByCurve” requires a decimal feet input…strange

 
Convert Meters To Feet02


#5

That worked a lot better. Thanks!

I still feel like there should be an easier way. I know I have seen videos where they did not do any conversions, or I didn’t see it and they didn’t bother to mention this step.