Excel nodes not working: error 80070002

I am pretty new with Dynamo and I have been struggling for an error that shows up with all the Excel Import and Export nodes. When using them, I receive the following error (80070002)

I’ve read everything about it on the forum and reinstalled Excel, upgraded Excel, upgraded Dynamo, updated Windows 10 to the last release, I have also deleted the 1.8 file in the registry…but nothing!

I am currently running:

Revit 2017.2
Dynamo 2.0
Office 365 Pro (32bit)

I tried with my colleague’s laptop (it is identical to mine) and it works!!! :frowning:

Any kind of help/suggestion will be appreciated, thank you!

Does it work if you do not have the excel document open?

I have faced this kind of error…! But it worked after a save and restart revit.

Hi @martin.scholl and @saju_autodesk, I tried saving and restarting Revit, and closing excel while working too. Unfortunately the problem is still there.

Not Sure what the problem exactly is.
But did you try other nodes that can read excel file like the Excel.ReadFromFile node…?

Every node related to excel does not work

I couldn’t really guess the reason.! last guess though you have installed ms office excel right?

I’d try uninstalling all of office, cleaning the registry of all associated keys, and then do a new install.

I already tried this way, with no luck :frowning:

If it may help as information, the error shows up even before browsing a file, which looks weird to me

Googled what this kind of error might mean and this came up:

1 Like