Error Parameter

Hi Forum
Unable to create Parameter ref attached snip.
Few parameters are missing every time.
Error Msg: The referenced object is not valid, possibly because it has been deleted from the database, or its creation was undone.
Kindly help
Thanks in advance

There can be a number of causes for this. I cant see what you are feeding into it for parameter name, but it seems you are feeding it a list of parameters, in which case you want to think about lacing and list leveling.

I am not a pro at lacing and list leveling, but basically what you want is the bottom 4 inputs to be run across every instance if the first input. I would change the list level of ParameterName to level 1 by clicking on the arrow to the right of it and changing that to 1. This will cause the node to deal with each element in that input list as its own list. It will then output a list of lists, which is really what you want, all of the associated information for each paramter name, each as a list.

It is also possible that one of your inputs is not the intended data type for the node. Group name for instance, I dont know that a string is the intended input for that node.

Another thing to keep in mind, this error is very common when running a graph multiple times directly from Dynamo. I will typically freeze the first node in the graph and then run it, and then unfreeze that node to “reset” the graph. Some nodes will attempt to process data they have already recieved vs processing the data as intended.

Hope some of this is helpful!

Hi J_Sanford Thank for replay
I am adding the Snip of Script for better understanding,

Run your script and then show what is being returned in the List.Flatten node. If you don’t know how to do that, hover your mouse over the word Auto and when the list shows move your mouse straight down to the list and you will see a push pin icon. Click that. FYI, I ran a test and got a Null return also, however it did create the shared parameter correctly and applied it to all categories. So with that, it’s probably one of the things you are feeding into the parameterName input that is causing the error. Also the Parameter.Create node should handle all items of a flattened list correctly with the lacing set to Auto.



By the way, that node doesn’t look for existing shared parameters with the same name, so if you run the script more than once, you will get the same result as I did when I had “Test” set as the parameterName.

You can see the return or output of that noid is a Void, which means a null is all you’ll ever get. It’s not meant to return the actual parameter.